Thursday, May 7, 2009

MPLS Traffic Engineering Tunnel and TE Router ID

When MPLS TE tunnel is configured between head end and tail end, the tunnel destination should match the TE router ID of the other end. If not the router will assume that it doesn’t have a valid path to the destination and RSVP will not be triggered. This will end up in tunnel remaining down.


A quick example will reveal the same,




R2#sh run

Building configuration...

Current configuration : 2442 bytes

!

ip cef

mpls traffic-eng tunnels

!

!

!

interface Loopback0

ip address 150.1.2.2 255.255.255.255

no ip directed-broadcast

!

interface Tunnel29

ip unnumbered Loopback0

no ip directed-broadcast

tunnel destination 9.9.9.9

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute metric absolute 100

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 10000

tunnel mpls traffic-eng path-option 1 explicit name EXP

interface FastEthernet0/1

ip address 150.1.29.2 255.255.255.0

no ip directed-broadcast

duplex full

speed 100

mpls traffic-eng tunnels

tag-switching ip

ip rsvp bandwidth 50000

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

router-id 150.1.2.2

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

ip explicit-path name EXP enable

next-address 150.1.29.9

next-address 9.9.9.9

!

!

tag-switching tdp router-id Loopback0 force

end

R2#


On R9, we have 2 loopback interfaces loopback0 and loopback9 configured. We use one loopback interface as TE router ID and use other loopback for tunnel ip address as below,

R9#show run

Building configuration...

Current configuration : 2585 bytes

ip cef

mpls traffic-eng tunnels

!

!

!

interface Loopback0

ip address 150.1.9.9 255.255.255.255

no ip directed-broadcast

!

interface Loopback9

ip address 9.9.9.9 255.255.255.255

no ip directed-broadcast

interface Tunnel29

ip unnumbered Loopback9

no ip directed-broadcast

tunnel destination 150.1.2.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute metric absolute 100

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 10000

tunnel mpls traffic-eng path-option 1 dynamic

!

interface FastEthernet0/1

ip address 150.1.29.9 255.255.255.0

no ip directed-broadcast

duplex full

speed 100

mpls traffic-eng tunnels

tag-switching ip

ip rsvp bandwidth

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

router-id 150.1.9.9

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

!

ip explicit-path name EXPLICIT enable

next-address 150.1.29.2

next-address 150.1.12.1

next-address 150.1.13.3

next-address 150.1.34.4

next-address 150.1.46.6

next-address 150.1.6.6

!

!

tag-switching tdp router-id Loopback0 force

end

R9#


With the above configuration, the tunnel at R9 will be up as the tunnel destination configured on R9 matches the TE router ID of R2.


R9#show int tun 29 | inc line protocol

Tunnel29 is up, line protocol is up

R9#

R9#show mpls traffic-eng tunnels tunnel 29

Name: R9_t29 (Tunnel29) Destination: 150.1.2.2

Status:

Admin: up Oper: up Path: valid Signalling: connected

R9#


But on R2, the tunnel will be down, as the tunnel destination configured on R2 tunnel doesn’t match R9’s TE router ID.


R2#show int tunnel 29 | inc line protocol

Tunnel29 is up, line protocol is down

R2#show mpls traffic-eng tunnel tunnel 29

Name: R2_t29 (Tunnel29) Destination: 9.9.9.9

Status:

Admin: up Oper: down Path: not valid Signalling: Down

path option 1, type explicit EXP

Last Error: PCALC:: Destination IP address, 9.9.9.9, not found

R2#


Now changing the TE router ID will solve the issue and bring the tunnel up.


R9(config)#router ospf 1

R9(config-router)#mpls traffic-eng router-id loopback 9

R9(config-router)#end

R9#

R2#show interface tunnel 29 | inc line protocol

Tunnel29 is up, line protocol is up

R2#

No comments:

Post a Comment